‫ VLC Media Player ASF Processing Buffer Overflow Vulnerability

IRCAD2013022451
ID: IRCAD2013022451
Release Date: 2013-01-30
Criticality level: Highly critical
 
Software:
VLC Media Player 2.x
 
Description:
A vulnerability has been reported in VLC Media Player, which can be exploited by malicious people to potentially compromise a user's system.
The vulnerability is caused due to an error in the "DemuxPacket()" function (modules/demux/asf/asf.c) when processing ASF files and can be exploited to cause a buffer overflow via a specially crafted ASF file.
Successful exploitation may allow execution of arbitrary code, but requires tricking a user into opening a malicious file.
The vulnerability is reported in versions 2.05 and prior.
 
Solution
The vulnerability will be fixed in upcoming version 2.0.6. No official solution is currently available.
 
References:
VideoLAN-SA-1302:
 
Secunia:

نظرات

بدون نظر
شما برای نظر دادن باید وارد شوید

نوشته

 
تاریخ ایجاد: 14 بهمن 1391

امتیاز

امتیاز شما
تعداد امتیازها:0