‫ كشف آسيب پذيري بحراني در Foxit Reader

شماره: IRCNE2013011729
تاريخ:24/10/91
 
Foxit Reader، نرم افزار مشاهده PDF كه اغلب به عنوان يك جايگزين براي نرم افزار محبوب Adobe Reader استفاده مي شود داراي يك آسيب پذيري بحراني در مولفه پلاگين خود است كه مي تواند توسط مهاجمان مورد سوء استفاده قرار بگيرد تا كد دلخواه را بر روي كامپيوترها اجرا نمايند.
جزئيات اين آسيب پذيري و چگونگي سوء استفاده از آن روز دوشنبه به صورت علني توسط Andrea Micalizzi منتشر شد
با توجه به راهنمايي امنيتي شركت Secunia، در حال حاضر اصلاحيه رسمي براي اين مساله وجود ندارد. اين شركت امنيتي اين رخنه را در رده امنيتي بالا قرار داده است زيرا مي تواند از راه دور براي بدست آوردن دسترسي سيستم مورد سوء استفاده قرار بگيرد.
توسعه دهندگان نرم افزار Foxit علت اين آسيب پذيري را شناسايي كرده اند و در حال كار بر روي اصلاحيه آن هستند. شركت امنيتي Secunia در راهنمايي امنيتي اعلام كرد كه اين آسيب پذيري به علت يك خطاي كرانه اي در پلاگين Foxit Reader براي مرورگر ها هنگام پردازش يك آدرس URL ايجاد شده است و مي تواند براي ايجاد يك سرريز بافر مبتني بر پشته از طريق يك نام فايل بلند در URL مورد سوء استفاده قرار بگيرد. سوء استفاده موفقيت آميز از اين آسيب پذيري ممكن است منجر به اجراي كد دلخواه گردد.
اين آسيب پذيري در npFoxitReaderPlugin.dll نسخه 2.2.1.530 تاييد شده است. نسخه هاي ديگر نيز ممكن است تحت تاثير اين آسيب پذيري قرار بگيرند.
Foxit Reader به طور پيش فرض پلاگين ها را براي مروگرهاي موزيلا فايرفاكس، گوگل كروم، اپرا و سافاري نصب مي كند.
Chaitanya Sharma، يكي از اعضاي گروه راهنمايي امنيتي در Secunia روز پنج شنبه گفت: اين آسيب پذيري از طريق فايرفاكس، اپرا و سافاري مورد سوء استفاده قرار مي گيرد. در حال حاضر به كاربران توصيه مي شود كه پلاگين مرورگر Foxit را براي فايرفاكس، كروم، اپرا و سافاري استفاده نكنند و به جاي آن براي مشاهده فايل هاي آنلاين PDF از اينترنت اكسپلورر استفاده نمايند.
 
مطالب مرتبط:

نظرات

بدون نظر
شما برای نظر دادن باید وارد شوید

نوشته

 
تاریخ ایجاد: 24 دی 1391

دسته‌ها

امتیاز

امتیاز شما
تعداد امتیازها:0