فا

‫ رفع چندين آسيب‌پذيری اجرای کد در محصولات VMWare

VMware به‌روزرسانی‌های امنیتی را برای رفع چهار آسیب‌پذیری در محصولات ESXi، vCenter Server Appliance (vCSA)، Workstation و Fusion منتشر کرده است.
کارشناسان امنیتی از گروه سیسکو تالوس، دو آسیب‌پذیری اجرای کد را کشف کردند که بر عملکرد مدیریت از راه دور VMware ESXi، Workstation و Fusion تأثیر می‌گذارد. درحالی‌که VMware آن‌ها را به‌عنوان آسیب‌پذیری‌های دارای شدت «مهم» طبقه‌بندی کرده است، سیسکو معتقد است که آن‌ها بحرانی هستند و به آن‌ها امتیاز CVSS 9.0 اختصاص داده است.
در توصیه‌های امنیتی منتشرشده از سیسکو، تالوس تعدادی آسیب‌پذیری را در اجرای VNC مورداستفاده در محصولات VMWare کشف کرده است که می‌تواند باعث اجرای کد شود. VMWare از VNC برای مدیریت از راه دور، دسترسی از راه دور و اهداف خودکارسازی خود در محصولات VMWare ازجمله Workstation، Player و ESXi بهره می‌گیرد. آسیب‌پذیری‌ها به گونه¬ایست که به مهاجم اجازه می‌دهند تا نشست VNC را آغاز کنند و باعث رخ¬دادن آسیب‌پذیری شوند.
اولین آسیب‌پذیری؛ آسیب‌پذیری CVE-2017-4941 در عملکرد مدیریت از راه دور VMWare است و می‌تواند توسط یک مهاجم از راه دور مورداستفاده قرار گیرد تا کد را در یک ماشین مجازی، با استفاده از VNC اجرا کند.
به گفته‌ی سیسکو، مجموعه‌ی خاصی از بسته‌های VNC، می‌تواند نوعی سردرگمی را به‌همراه داشته باشد که موجب بازنشانی پشته و منجر به اجرای کد شود.
مسئله‌ی دوم کشف‌شده توسط سیسکو تالوس، خطای سرریز پشته است که با شناسه¬ی CVE-2017-4933 ردیابی می‌شود و می‌تواند با استفاده از بسته‌های ویژه‌ی VNC ، توسط مهاجم برای اجرای کد دلخواه در یک ماشین مجازی، اجرا شود.
طبق توصیه‌ی امنیتی سیسکو، یک آسیب‌پذیری اجرای کد در عملکرد مدیریت از راه دور VMware وجود دارد. مجموعه‌ای از بسته‌های ویژه‌ی VNC می‌توانند موجب سرریز پشته شوند. مهاجم باید یک نشست VNC برای استفاده از این آسیب‌پذیری ایجاد کند.
VMware اشاره کرده است که سوءاستفاده از این آسیب‌پذیری در ESXi تنها زمانی امکان‌پذیر است که VNC به‌صورت دستی در فایل پیکربندی VM فعال شده باشد و برنامه‌ی کاربردی طوری تنظیم شده باشد که اجازه‌ی عبور VNC از طریق فایروال را بدهد.
VMware همچنین یک نقص XSS را که با شناسه¬ی CVE-2017-4940 قابل ردیابی است و بر روی ESXi Host Client تأثیر می‌گذارد، وصله کرد. این آسیب‌پذیری به مهاجم اجازه تزریق کدی را در حالتی که کاربر به Host Client دسترسی پیدا می‌کند، به وی می¬دهد.
نقص چهارم که توسط VMWare مورد بررسی قرار گرفت، یک افزایش مجوز است که بر vCSA تأثیر می‌گذارد و با شناسه¬ی CVE-2017-4943 ردیابی می‌شود. این آسیب‌پذیری در افزونه‌ی "showlog" قرار دارد و می‌تواند توسط مهاجمی با امتیازات کم برای دستیابی به دسترسی ریشه به سیستم‌عامل پایه‌ی دستگاه، مورد سوء‌استفاده قرار گیرد.
VMware این آسیب‌پذیری‌ها را با انتشار شش وصله‌ی مختلف برای ESXi، نسخه‌ی 12.5.8 از Workstation، نسخه‌ی 8.5.9 از Fusion و نسخه‌ی 6.5 U1d از vCSA رفع كرد


نظرات

بدون نظر
شما برای نظر دادن باید وارد شوید

نوشته

 
تاریخ ایجاد: 12 دی 1396

دسته‌ها

امتیاز

امتیاز شما
تعداد امتیازها: 0