en

‫ كشف آسيب پذيري جديد در Mac OS X

شماره: IRCNE2015072576
تاريخ:05/03 /94
 
محققان امنيتي آلماني يك آسيب پذيري افزايش حق دسترسي را در OS X كشف كردند كه در آخرين به روز رساني هاي منتشر شده توسط اپل اصلاح نشده است. اين آسيب پذيري OS X نسخه 10.10.x را تحت تاثير قرار مي دهد و مربوط به ويژگي جديد اضافه شده به آي پدها و آيفون ها مي باشد.
ويژگي هاي جديدي كه باعث به وجود آمدن اين آسيب پذيري شده اند مربوط به لينك پوياي dyld و متغير محيطي DYLD_PRINT_TO_FILE مي باشد.
هنگامي كه اين متغير جديد اضافه شده است، حفاظت هاي امنيتي متداول كه هنگام افزودن متغيرهاي محيطي به لينك هاي پويا نياز است استفاده نشده است. در نتيجه اين امكان وجود دارد كه بتوان از اين ويژگي جديد حتي با باينري هاي SUID استفاده شود. اين مساله خطرناك است زيرا باعث مي شود تا فايل هاي دلخواه متعلق به كاربر root در هر جايي از فايل سيستم باز شده يا ايجاد شود.
به علاوه لاگ فايل باز شده هيچگاه بسته نمي شود و اين مساله مي تواند باعث شود تا فرآيندهاي خرد از فرآيند SUID بتوانند در فايل هاي دلخواه متعلق به كاربر root در هرجايي از سيستم فايل بنويسند. نتيجه اين اقدامات مي تواند منجر به افزايش حق دسترسي و در اختيار گرفتن كامل سيستم قرباني شود.
محققان امنيتي جزئيات كامل اين آسيب پذيري را به همراه كد سوء استفاده تشريح كردند و هشدار دادند كه اجراي اين كد بر روي سيستم هايي كه به عنوان پوسته root نصب شده اند خطرناك است.
يكي از محققان امنيتي گفت: معلوم نيست كه شركت اپل از وجود اين آسيب پذيري مطلع است يا خير. زيرا اين آسيب پذيري در آخرين اصلاحيه هاي اين شركت مربوط به OS X 10.10.4 و نسخه بتاي اخير OS X 10.10.5 برطرف نشده است.
در ماه ژوئيه، شركت اپل يك به روز رساني امنيتي براي اصلاح 12 آسيب پذيري امنيتي در iOS 8.4 و OS X 10.10.4 منتشر كرد.

  


The Wall

No comments
You need to sign in to comment