فا

‫ آسيب پذيري Word Press

  

آسيب پذيري Word Press

 
1 Wordpress چيست ؟

وردپرس يك سيستم مديريت محتوا كاملا رايگان و اپن سورس هست ( بر پايه مجوز GPL ) كه شما به وسيله آن قادر خواهيد بود به راحتي يك وبلاگ، فوتوبلاگ، پادكست، گالري و … بسازيد. وردپرس توسط زبان بسيار محبوب PHP نوشته شده و از قدرت MySQL  براي ذخيره داده ها استفاده مي كند.
استفاده از اين سيستم به دليلي سادگي، انعطاف بالا، قالب هاي بسيار زياد، امنيت بالا و ... بسيار رايج است. در آخرين نسخه از اين سيستم يك آسيب پذيري از نوع  SQL Injectionداراي شناسه آسيب پذيري CVE-2015-2213 پيدا شده است. اين آسيب پذيري كه در بخش ويرايش نظرات Wordpress قرار دارد تمامي نسخه هاي قبل از نسخه 4.2.3 را تحت شعاع قرار ميدهد. با توجه به اينكه براي استفاده از اين آسيب پذيري شخص جمله كننده الزاما بايد داراي دسترسي به بخش مديريت داشته باشد، بنابراين ريسك نفوذ از طريق اين آسيب بسيار پايين است. بيشترين خطر در كمين سايت هايي است كه داراي چندين كاربر با سطح دسترسي مديريتي هستند.
2 تحليل فني آسيب پذيري
آسيب پذيري ياد شده در بخش مديريت و مربوط به وضعيت نظرات پست ها در زمان بازگرداندن پست از زباله¬دان مي باشد. شخص حمله كننده در ابتدا با استفاده از تغيير رشته ي مربوط به وضعيت نظر، دستورات SQL خود را وارد ميكند. سپس با ارسال پست مربوط به آن نظر به زباله دان و بازگرداندن آن، دستورات SQL اي كه در رشته ي وضعيت وارد كرده را اجرا ميكند


نظرات

بدون نظر
شما برای نظر دادن باید وارد شوید

نوشته

 
تاریخ ایجاد: 9 شهریور 1394

دسته‌ها

امتیاز

امتیاز شما
تعداد امتیازها:0