‫ اصلاح آسيب پذيري اجراي كد از راه دور در Samba

شماره: IRCNE2015022434
تاريخ: 06/12/93
 
محققان امنيتي به كاربران نرم افزار سامبا هشدار دادند كه به منظور اصلاح يك آسيب پذيري، به روز رساني هاي امنيتي جديد اين نرم افزار را نصب نمايند. اين آسيب پذيري بحراني به مهاجمان اجازه مي دهد تا از راه دور و با حق دسترسي root كدي دلخواه را اجرا نمايند.
نرم افزار سامبا يك پياده سازي از پروتكل شبكه SMB/CIFS مي باشد كه باعث مي شود سيستم هاي شبيه يونيكس مانند لينوكس، BSD، سولاري و Mac OS X بتوانند فايل ها و پرنترها را با سيستم هاي ويندوز به اشتراك بگذارند. هم چنين اين نرم افزار باعث مي شود تا اين سيستم ها بتوانند با محيط اكتيو دايركتوري ويندوز يكپارچه شده و حتي به عنوان كنترل كننده دامنه عمل نمايند.
اين آسيب پذيري جديد در فايل سرور smbd قرار گرفته است و توسط Richard van Eeden از گروه تحقيقات آسيب پذيري ويندزو كشف شده است.
گروه امنيتي Red Hat در وبلاگي نوشت: اين آسيب پذيري مي تواند توسط يك كلاينت خرابكار سامبا و از طريق ارسال بسته هاي دستكاري شده خاص به سرور سامبا مورد سوء استفاده قرار بگيرد. براي سوء استفاده از اين نقص هيچگونه تاييد هويت نياز نيست. اين مساله مي تواند باعث شود تا مهاجمان بتوانند از راه دور و با دسترسي root كدي دلخواه را اجرا نمايند.
تمامي نسخه هاي سامبا از 3.5.0  تا4.2.0rc4  آسيب پذير مي باشند. گروه پروژه سامبا براي اصلاح اين مشكل نسخه هاي 4.2.0rc5، 4.1.17، 4.0.25 و 3.6.25 را منتشر كرده است.
براي سامبا نسخه 4.0.0 و نسخه هاي پس از آن يك چارچوب كاري دستي وجود دارد كه شامل افزودن يك خط كد rpc_server:netlogon=disabled به بخش [global] در فايل smb.conf مي باشد.
كاربران بايد در اسرع وقت به روز رساني هاي موجود براي سامبا را بر روي سيستم هاي خود نصب نمايند.
 

 


نظرات

بدون نظر
شما برای نظر دادن باید وارد شوید

نوشته

 
تاریخ ایجاد: 6 اسفند 1393

دسته‌ها

امتیاز

امتیاز شما
تعداد امتیازها:0