فا

‫ آسيب پذيري آپلود فايل دلخواه در WordPress Nmedia Users File Uploader Plugin

IRCAD2012072079
شماره:IRCAD2012072079
تاريخ انتشار:19-07-2012
ميزان حساسيت: بسيار مهم
نرم افزارهاي تحت تاثير:
WordPress Nmedia Users File Uploader Plugin 1.x
توضيح:
يك آسيب پذيري در پلاگين Nmedia Users File Uploader براي وردپرس كشف شده است كه مي تواند توسط افراد خرابكار مورد سوء استفاده قرار بگيرد تا كنترل يك سيستم آسيب پذير را در اختيار بگيرند.
اين آسيب پذيري به علت اسكريپت wp-content/plugins/nmedia-user-file-
uploader/doupload.php ايجاد شده است كه به فايل هاي با پسوند دلخواه اجازه مي دهد تا داخل فولدر webroot آپلود شوند. اين مساله مي تواند براي اجراي كد PHP دلخواه بوسيله آپلود كردن يك اسكريپت PHP مخرب مورد سوء استفاده قرار بگيرد.
اين آسيب پذيري در نسخه 1.8 تاييد شده است. نسخه هاي ديگر نيز ممكن است تحت تاثير اين آسيب پذيري قرار بگيرند.
راهكار:
به نسخه 2.0 ارتقاء دهيد.
منابع:
Nmedia Users File Uploader Plugin:
Secunia:

نظرات

بدون نظر
شما برای نظر دادن باید وارد شوید

نوشته

 
تاریخ ایجاد: 1 آذر 1387

امتیاز

امتیاز شما
تعداد امتیازها: 0