‫ آسيب پذيري آپلود فايل دلخواه در WordPress WP-Property Plugin

IRCAD2012061951
شماره: IRCAD2012061951
تاريخ انتشار:2012-06-06
ميزان حساسيت: بسيار مهم
نرم افزارهاي تحت تاثير: 
 
WordPress WP-Property Plugin 1.x
توضيح:
يك آسيب پذيري در پلاگينWP-Property    در وردپرس كشف شده است كه مي تواند توسط افراد خرابكار مورد سوء استفاده قرار بگيرد تا كنترل يك سيستم آسيب پذير را در اختيار بگيرند.
اين آسيب پذيري به علت يك اسكريپت wp-content/plugins/wp-property/third-party/uploadify/uploadify.php  ايجاد شده است كه اجازه مي دهد تا فايل ها با پسوندهاي دلخواه در يك فولدر داخلي در webroot آپلود شوند. اين مساله مي تواند براي اجراي كد PHP دلخواه بوسيله آپلود كردن يك اسكريپ PHP مخرب مورد سوء استفاده قرار بگيرد.
اين آسيب پذيري در نسخه 1.35.0 تاييد شده است. نسخه هاي ديگر نيز ممكن است تحت تاثير اين آسيب پذيري قرار بگيرند.
 
راهكار:
دسترسي بهwp-content/plugins/wp-property/third-party/uploadify/uploadify.php   را محدود نماييد.
منابع:
Secunia:
 
 
 

نظرات

بدون نظر
شما برای نظر دادن باید وارد شوید

نوشته

 
تاریخ ایجاد: 18 خرداد 1391

امتیاز

امتیاز شما
تعداد امتیازها:0