‫ آسيب پذيري آپلود فايل دلخواه در WordPress FoxyPress Plugin

IRCAD2012061948
شماره: IRCAD2012061948
تاريخ انتشار:2012-06-06
ميزان حساسيت: بسيار مهم
نرم افزارهاي تحت تاثير: 
 
WordPress FoxyPress Plugin 0.x
توضيح:
يك آسيب پذيري در پلاگين FoxyPress در وردپرس كشف شده است كه مي تواند توسط افراد خرابكار مورد سوء استفاده قرار بگيرد تا كنترل يك سيستم آسيب پذير را در اختيار بگيرند.
اين آسيب پذيري به علت يك اسكريپت wp-content/plugins/foxypress/uploadify/uploadify.php ايجاد شده است كه اجازه مي دهد تا فايل ها با پسوندهاي دلخواه در يك فولدر داخلي در webroot آپلود شوند. اين مساله مي تواند براي اجراي كد PHP دلخواه بوسيله آپلود كردن يك اسكريپ PHP مخرب مورد سوء استفاده قرار بگيرد.
اين آسيب پذيري در نسخه 0.4.2.1 تاييد شده است. نسخه هاي ديگر نيز ممكن است تحت تاثير اين آسيب پذيري قرار بگيرند.
 
راهكار:
دسترسي به wp-content/plugins/foxypress/uploadify/uploadify.php را محدود نماييد.
منابع:
Secunia:
 
 

نظرات

بدون نظر
شما برای نظر دادن باید وارد شوید

نوشته

 
تاریخ ایجاد: 18 خرداد 1391

امتیاز

امتیاز شما
تعداد امتیازها:0