en

‫ آسيب پذيري include كردن فايل abspath در پلاگين Relocate Upload در وردپرس

IRCAD2012021719
شماره:IRCAD2012021719
تاريخ انتشار:  14-02-2012
ميزان حساسيت: بسيار مهم
نرم افزارهاي تحت تاثير:
WordPress Relocate Upload Plugin 0.x
 
توضيح:
يك آسيب پذيري در پلاگين Relocate Upload در وردپرس كشف شده است كه مي­تواند توسط افراد خرابكار مورد سوء استفاده قرار گيرد تا كنترل يك سيستم آسيب پذير را در اختيار بگيرند.
ورودي ارسال شده از طريق پارامتر abspath به wp-content/plugins/relocate_upload/relocate-upload.php پيش از استفاده در فايل­هاي include به صورت مناسب امن سازي نمي­گردد. اين مساله مي­تواند براي include كردن فايل­هاي دلخواه از منابع محلي يا خارجي مورد سوء استفاده قرار گيرد.
اين آسيب پذيري در نسخه 0.14 تاييد شده است. نسخه هاي پيشين نيز ممكن است تحت تاثير اين آسيب پذيري قرار داشته باشند.
 
راهكار:
به نسخه 0.20 به روز رساني نماييد.
 
منابع:

The Wall

No comments
You need to sign in to comment