en

‫ آسيب پذيري include كردن فايل npath در پلاگين Eventify در WordPress

IRCAD2011101470
شماره:IRCAD2011101470
تاريخ انتشار: 07-10-2011
ميزان حساسيت: بسيار مهم
نرم افزارهاي تحت تاثير:
WordPress Eventify Plugin 1.x
توضيح:
يك آسيب پذيري در پلاگين Eventify براي وردپرس كشف شده است كه مي­تواند توسط افراد خرابكار مورد سوء استفاده قرار گيرد تا كنترل يك سيستم آسيب پذير را در اختيار بگيرند.
ورودي ارسال شده از طريق پارامتر npath در wp-content/plugins/eventify/php/ajax/fetcheventdetails.php پيش از استفاده در فايل­هاي include به خوبي مورد ارزيابي قرار نمي­گيرد. اين مساله مي­تواند براي include كردن فايل­هاي دلخواه از منابع محلي يا خارجي مورد سوء استفاده قرار گيرد.
اين آسيب پذيري در نسخه 1.7.g تاييد شده است. نسخه هاي پيشين نيز ممكن است تحت تاثير اين آسيب پذيري قرار داشته باشند.
راهكار:
به نسخه 1.7.h به روز رساني نماييد.
منابع:

The Wall

No comments
You need to sign in to comment