فا

‫ آسيب پذيري بارگذاري فايل دلخواه در پلاگين SmoothGallery در وردپرس

IRCAD2011101459
شماره:IRCAD2011101459
تاريخ انتشار: 04-10-2011
ميزان حساسيت: بسيار مهم
نرم افزارهاي تحت تاثير:
WordPress SmoothGallery Plugin 1.x
توضيح:
يك آسيب پذيري در پلاگين SmoothGallery براي وردپرس كشف شده است كه مي­تواند توسط افراد خرابكار مورد سوء استفاده قرار گيرد تا كنترل يك سيستم آسيب پذير را در اختيار بگيرند.
ورودي ارسال شده از طريق پارامتر src در wp-content/plugins/smoothgallery/extra/resizer.php پيش از استفاده در فايل­هاي cache شده به خوبي مورد ارزيابي قرار نمي­گيرد. اين مساله مي­تواند براي بارگذاري و اجراي فايل­هاي PHP دلخواه مورد سوء استفاده قرار گيرد.
اين آسيب پذيري در نسخه 1.15.1 تاييد شده است. نسخه هاي پيشين نيز ممكن است تحت تاثير اين آسيب پذيري قرار داشته باشند.
راهكار:
به نسخه 1.15.2 به روز رساني نماييد.
منابع:

نظرات

بدون نظر
شما برای نظر دادن باید وارد شوید

نوشته

 
تاریخ ایجاد: 25 بهمن 1390

امتیاز

امتیاز شما
تعداد امتیازها: 0