en

‫ آسيب پذيري در پلاگين Zingiri Web Shop در وردپرس

IRCAD2011091416
شماره:IRCAD2011091416
تاريخ انتشار: 20-09-2011
ميزان حساسيت: بسيار مهم
نرم افزارهاي تحت تاثير:
WordPress Zingiri Web Shop Plugin 2.x
توضيح:
يك آسيب پذيري در پلاگين Zingiri Web Shop براي وردپرس كشف شده است كه مي­تواند توسط افراد خرابكار مورد سوء استفاده قرار گيرد تا كنترل يك سيستم آسيب پذير را در اختيار بگيرند.
ورودي ارسال شده از طريق پارامتر wpabspath به wp-content/plugins/zingiri-web-shop/fws/ajax/init.inc.php و wp-content/plugins/zingiri-web-shop/fwkfor/ajax/init.inc.php پيش از استفاده در فايل­هاي include به خوبي مورد بازبيني قرار نمي­گيرد. اين مساله مي­تواند براي include كردن فايل­هاي دلخواه از منابع محلي يا خارجي مورد سوء استفاده قرار گيرد.
اين آسيب پذيري در نسخه 2.2.0 تاييد شده است. نسخه هاي پيش از آن نيز ممكن است تحت تاثير اين آسيب پذيري قرار داشته باشند.
راهكار:
به نسخه 2.2.1 به روز رساني نماييد.
منابع:

The Wall

No comments
You need to sign in to comment