en

‫ چندين مساله امنيتي آپلود فايل در پلاگين WordPress Grapefile

IRCAD2011091383
شماره:IRCAD2011091383
تاريخ انتشار:  01-09-2011
ميزان حساسيت: بسيار مهم
نرم افزارهاي تحت تاثير:
WordPress Grapefile Plugin 1.x
 
توضيح:
چندين مساله امنيتي در پلاگين Grapefile براي WordPress كشف شده است كه مي­توانند توسط افراد خرابكار مورد سوء استفاده قرار گيرند تا كنترل يك سيستم آسيب پذير را در اختيار بگيرند.
اين مسائل امنيتي به علت عدم محدوديت­هاي دسترسي به اسكريپت­هاي wp-content/plugins/grapefile/grapeupload.php، wp-content/plugins/grapefile/grapeupload2.php، wp-content/plugins/grapefile/grapeupload3.php و wp-content/plugins/grapefile/grapeupload4.php ايجاد شده است. اين مسائل امنيتي مي­توانند براي بارگذاري فايل­هاي دلخواه در فولدرهاي wp-content/plugins/grapefile/filestore/avi، wp-content/plugins/grapefile/filestore/doc، wp-content/plugins/grapefile/filestore/mp3 و wp-content/plugins/grapefile/filestore/zip در داخل webroot و اجراي كد PHP دلخواه مورد استفاده قرار گيرند.
اين مسائل امنيتي در نسخه 1.1 تاييد شده اند. ساير نسخه ها نيز ممكن است تحت تاثير قرار داشته باشند.
 
راهكار:
دسترسي به اسكريپت­هاي grapeupload.php، grapeupload2.php، grapeupload3.php و grapeupload4.php را محدود نماييد (براي مثال از طريق .htaccess)
 
منابع:

The Wall

No comments
You need to sign in to comment