فا

‫ phpMyAdmin Multiple Vulnerabilities

IRCAD2011071316
ID:IRCAD2011071316
Release Date: 2011-07-25
Criticality level: Highly critical
 
Software:
phpMyAdmin 3.x
 
Description:
Multiple vulnerabilities have been reported in phpMyAdmin, which can be exploited by malicious users to conduct cross-site scripting attacks and potentially compromise a vulnerable system and by malicious people to disclose potentially sensitive information and potentially compromise a vulnerable system.
 
1) Certain input passed to the table name in the table print view script is not properly sanitised before being returned to the user. This can be exploited to execute arbitrary HTML and script code in a user's browser session in context of an affected site.
 
Successful exploitation of this vulnerability requires that a specially crafted table name exists.
 
The vulnerability is reported in version 3.4.3.1 and earlier.
 
2) Certain input passed to the MIME-type transformation parameter is not properly verified before being used to include files. This can be exploited to include arbitrary files from local resources.
 
Successful exploitation of this vulnerability requires that the configuration storage mechanism is configured.
 
3) Certain input passed to an unspecified parameter in the 'relational schema' code is not properly sanitised before being used to concatenate a class name. This can be exploited to include arbitrary files from local resources.
 
The vulnerabilities #2 and #3 are reported in version 3.4.0 through 3.4.3.1.
 
4) An unspecified error within the Swekey authentication can be exploited to overwrite session variables.
 
The vulnerability is reported version 3.4.3.1 and earlier.
 
Solution:
Update to version 3.3.10.3 or 3.4.3.2.
 
References:
PMASA-2011-9:
 
PMASA-2011-10:
 
PMASA-2011-11:
 
PMASA-2011-12:
 
Frans Pehrson:
 
Secunia:
 
 

نظرات

بدون نظر
شما برای نظر دادن باید وارد شوید

نوشته

 
تاریخ ایجاد: 25 بهمن 1390

امتیاز

امتیاز شما
تعداد امتیازها: 0