en

‫ Oracle Solaris Multiple Vulnerabilities

IRCAD2011071309
ID:IRCAD2011071309
Release Date: 2011-07-20
Criticality level: Highly critical
Software:
Oracle Solaris 11 Express
Sun Solaris 10
Sun Solaris 8
Sun Solaris 9
 
Description:
Multiple vulnerabilities have been reported in Sun Solaris, which can be exploited by malicious, local users to cause a DoS (Denial of Service) or gain escalated privileges, malicious users to cause a DoS, and malicious people to cause a DoS or potentially compromise a vulnerable system.
1)      An unspecified error in fingerd can be exploited to cause the system to hang or crash via specially crafted requests.
The vulnerability is reported in versions 8, 9, 10, and 11 Express.
2)      An unspecified error in the SSH component can be exploited to potentially compromise a vulnerable system.
The vulnerability is reported in versions 9 and 10.
3)      An unspecified error in the Installer component can be exploited to gain escalated privileges.
The vulnerability is reported in version 10.
4)      An unspecified error in the TCP/IP implementation can be exploited by authenticated users to crash the system.
The vulnerability is reported in versions 8, 9, and 10.
5)      An unspecified error in the SSH component can be exploited to cause the service to stop responding or crash.
The vulnerability is reported in versions 10 and 11 Express.
6)      An unspecified error in the KSSL component can be exploited to cause a service to stop responding or crash.
The vulnerability is reported in versions 10 and 11 Express.
7)      An unspecified error in the Kernel/SCTP component can be exploited to cause a local DoS.
The vulnerability is reported in version 11 Express.
8)      An unspecified error in the Kernel/sockfs component can be exploited to cause a local DoS.
The vulnerability is reported in versions 10 and 11 Express.
9)      An unspecified error in the UFS component can be exploited to cause a local DoS.
The vulnerability is reported in versions 8, 9, 10, and 11 Express.
10)   An unspecified error in the Zones component can be exploited to cause a local DoS.
The vulnerability is reported in version 11 Express.
11)   An unspecified error in the Driver/USB component can be exploited to cause a local DoS.
The vulnerability is reported in versions 8, 9, 10, and 11 Express.
12)   An unspecified error in the rksh component can be exploited to perform certain actions with escalated privileges.
The vulnerability is reported in versions 8, 9, 10, and 11 Express.
13)   An unspecified error in the LiveUpgrade component can be exploited to manipulate certain data or cause a local DoS.
The vulnerability is reported in version 10.
14)   An unspecified error in the Trusted Extensions component can be exploited to gain escalated privileges.
The vulnerability is reported in version 10.
 
Solution:
Apply updates.
 
References:
Oracle:
 
Secunia:
 

The Wall

No comments
You need to sign in to comment