فا

‫ استفاده بسياري از وب سايت هاي آپاچي از نسخه هاي قديمي و آسيب پذير

شماره: IRCNE2014022096
تاريخ:20/11/92
 

با توجه به تحقيقات موسسه Netcraft، تعداد بسيار كمي از سرورهاي آپاچي از نسخه كاملا اصلاح شده آن استفاده مي كنند. بسياري از سايت هاي محبوب و معروف بر روي نسخه قديمي، آسيب پذير و اصلاح نشده از آپاچي ميزباني مي شوند.

آخرين نسخه منتشر شده از Apache Stable نسخه 2.4.7 مي باشد كه در 25 نوامبر سال 2013 منتشر شد. تعداد بسيار كمي از سايت ها از اين نسخه استفاده مي كنند. بنا به گزارشات ارسالي كمتر از يك درصد از سايت ها در حال استفاده از نسخه هاي 2.4 مي باشند در صورتي كه شركت آپاچي به كاربران توصيه اكيد كرده است كه از نسخه هاي 2.4 استفاده نمايند. برخي از سروهاي آپاچي از نسخه هاي مربوط به 2.2 آپاچي استفاده مي كنند و آخرين به روز رساني اين نسخه مربوط به 18 نوامبر سال 2013 نسخه 2.2.26 مي باشد. حتي بسياري از سايت هاي محبوب و معروف در حال حاضر از نسخه هاي سري 1.3.x آپاچي استفاده مي كنند و بسياري از آن ها در حال اجراي نسخه 1.3.42 مي باشند.  

با توجه به يافته هاي Netcraft، بيش از نيمي از وب سايت هاي آپاچي نسخه خود را مخفي نگه مي دارند اگر چه با برخي راهكارها مي توان نسخه آن را بدست آورد. برخي از سرورها با نسخه آسيب پذير ممكن است نسبت به رخنه هاي موجود درآن نسخه آسيب پذير نباشند.

مي توان گفت كه نسخه هاي 2.2.x غالب مي باشند و هم چنان توسط بسياري از برنامه ها مانند Red Hat مورد استفاده قرار مي گيرند. و هم چنين بسياري از سايت هايي كه امنيت يك نگراني اساسي براي آن ها به شمار مي رود مانند OpenSSL از نسخه هاي قديمي آپاچي استفاده مي كنند. OpenSSL.org از نسخه 2.2.22 آپاچي بر روي Ubuntu Linux استفاده مي كند.

 


نظرات

بدون نظر
شما برای نظر دادن باید وارد شوید

نوشته

 
تاریخ ایجاد: 20 بهمن 1392

دسته‌ها

امتیاز

امتیاز شما
تعداد امتیازها: 0